WHDLoad не видит файл кикстарта

Описания, прохождение, секреты, и прочее про амижные игры.

Модераторы: striimii, Vinnny

WHDLoad не видит файл кикстарта

Сообщение jd69 05 дек 2008, 14:21

Заранее извиняюсь, если написал не в ту ветку.
В общем есть амига 600HD. Кикстарт 37.300. Внутри винчестер ~700мб (мастер) и CF карта с переходником на IDE (слейв). Из примочек есть только FastRam 8mb 2007 года. На винте установлена Workbench 2.1 голая, из софта только WHDLoad 16.8 (16.7, 16.6, 14.5 - это все версии которые я пробовал). Дело в том, что некоторые игры просят дать им файлы кикстарта от амиги 500-ой (kick34005.A500.RTB и kick34005.A500). Их надо положить в DEVS:Kickstarts. Ложу их туда, запускаю игру, она вываливается и пишет - "kickstart file is invalid". В этом вся и проблема. Какие я только кикстарты туда не заливал, он всё равно даёт эту ошибку. При том, что на эмуляторе (WinUAE, конфигурация выставлена аналогичная) во всех вариантах всё работает нормально.
Помогите пожалуйста кто знает :(
jd69
Проходил мимо
Проходил мимо
 
Сообщения: 6
Зарегистрирован: 10 ноя 2008, 13:28

Re: WHDLoad не видит файл кикстарта

Сообщение Vinnny 05 дек 2008, 16:39

чем-то типа snoopdos посмотреть какие именно названия файлов и по каким путям пытается загрузить whdload.
Pegasos2+Efika, MorphOS registered
Amiga1200, Blizzard030, AmigaOS
ПэЦэ, вЕнда
Аватара пользователя
Vinnny
Менеджер
Менеджер
 
Сообщения: 2416
Зарегистрирован: 18 май 2002, 12:56
Откуда: NiNo

Re: WHDLoad не видит файл кикстарта

Сообщение easy_john 05 дек 2008, 16:59

да нет, все правильно, она ищет в devs:kickstart/kick34005.A500
*.pat *.rtb ставятся вместе с дистрибутивом skick(?), и whdload нормально все находит.
кикстарты я брал из tosec, просто переименовывал.
может вариант, что у тебя для whd не хватает chip памяти? все же 1 метр это не много, хорошо бы два.
PegasosII G4 1.0/1Gb/80Gb/Ati 9200/MorphOS unreg/Debian
a4000/PPC 233mhz/68060 50mhz/128mb/cv ppc/toccata/x-surf/kickflash/indivision/AOS3.9-4.0
a1200/PPC 200mhz/68040 25mhz/256mb/bv ppc/delfina/wifi/indivision sd+ff/AOS 3.9-4.0
a600/68000 7mhz/8mb fast/wifi/AOS 3.0
Аватара пользователя
easy_john
Менеджер
Менеджер
 
Сообщения: 4296
Зарегистрирован: 03 мар 2006, 15:24
Откуда: SPb

Re: WHDLoad не видит файл кикстарта

Сообщение jd69 05 дек 2008, 17:20

У меня 2 метра чипа. И 8 фаста. Это та амига, которую нам с отцом продал skyther.
Попробовал залить все (*.pat *.rtb и *.A500) файлы, вываливается и пишет вот такое:
error during 'resload_LoadKick'
invalid kickstart image
[Quit][Restart][Make CoreDump]

В эмуляторе достаточно файла A500 и RTB, а амига даже не признает ни одного :(
jd69
Проходил мимо
Проходил мимо
 
Сообщения: 6
Зарегистрирован: 10 ноя 2008, 13:28

Re: WHDLoad не видит файл кикстарта

Сообщение easy_john 05 дек 2008, 17:48

хм. размер maxtransfer для всех разделов указан правильно?
впечатление что или у тебя где-то что-то сбоит или я не знаю. :)
PegasosII G4 1.0/1Gb/80Gb/Ati 9200/MorphOS unreg/Debian
a4000/PPC 233mhz/68060 50mhz/128mb/cv ppc/toccata/x-surf/kickflash/indivision/AOS3.9-4.0
a1200/PPC 200mhz/68040 25mhz/256mb/bv ppc/delfina/wifi/indivision sd+ff/AOS 3.9-4.0
a600/68000 7mhz/8mb fast/wifi/AOS 3.0
Аватара пользователя
easy_john
Менеджер
Менеджер
 
Сообщения: 4296
Зарегистрирован: 03 мар 2006, 15:24
Откуда: SPb


Вернуться в Игры

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron